Installing 10gR2 – pre-requisites, errors and solutions

Problemas con librerias.

Para realizar una optima instalación de un motor de base de datos, u OAS es importante chequear bien lo prerequisitos de la documetación oficial.

Red Hat Enterprise Linux 4.0:

binutils-2.15.92.0.2-10.EL4
compat-db-4.1.25-9
control-center-2.8.0-12
gcc-3.4.3-9.EL4
gcc-c++-3.4.3-9.EL4
glibc-2.3.4-2
glibc-common-2.3.4-2
gnome-libs-1.4.1.2.90-44.1
libstdc++-3.4.3-9.EL4
libstdc++-devel-3.4.3-9.EL4
make-3.80-5
pdksh-5.2.14-30
sysstat-5.0.5-1
xscreensaver-4.18-5.rhel4.2

Algunas veces ocurre que trabajamos con servidores bajo plataformas de 32bits (i386) o 64bits (x86_64) y esto es imortante tenerlo en cuenta a la hora de la instalación de los paquetes necesarios.

Ahora bien, cuando tenemos instalado un sistema operativo de 64 bits en un servidor de 64 bits, si queremos correr binarios o aplicaciones construidas bajo 32 bits, va a precisar que estas esten instaladas estas librerias.

Ejemplo para una aplicación de Python que corre en 64bits.

|Bin       | Lib               |  ArCh  |
|sqlplus   | setuptools-0.6c11 | x86_64 |
|sqlplus   | setuptools-0.6c11 |  i386  |

En el caso puntual que voy a exponer como problema, transcurre en un Red Hat 4, y para ver un mejor detalle de la version del SO, voy a ejecutar un cat sobre el archivo /etc/issue

[root@sdat4104lx ~]# cat /etc/issue
Red Hat Enterprise Linux ES release 4 (Nahant Update 8)
Kernel \r on an \m

Read more of this post

Follow

Get every new post delivered to your Inbox.

Join 129 other followers

%d bloggers like this: